const regex = new RegExp('(?m)(?:^```\\h*\\S+\\s+\\K|\\G(?!\\A))^(?!```)(.*\\R+)(?:```)?', 'g')
const str = `Do not change this line
\`\`\`markdown
Sasha great!
Sasha nice!
She is beautiful, surprise!
\`\`\`
Do not change this line
Do not change this line
\`\`\`markdown
Sasha great!
Sasha nice!
She is beautiful, surprise!
\`\`\`
Do not change this line
Do not change this line
\`\`\`markdown
Sasha great!
Sasha nice!
She is beautiful, surprise!
\`\`\`
Do not change this line
Do not change this line
\`\`\`markdown
Sasha great!
Sasha nice!
She is beautiful, surprise!
\`\`\`
Do not change this line`;
const subst = `\t\1`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);