const regex = /(_)[^_]*$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(_)[^_]*$', 'gm')
const str = `012344_2.0224.71_3
012354_5.00123.AR_3.335_8`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}