$re = '/(_)[^_]*$/m';
$str = '012344_2.0224.71_3
012354_5.00123.AR_3.335_8';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);