import re
regex = re.compile(r"(_)[^_]*$", flags=re.MULTILINE)
test_str = ("012344_2.0224.71_3\n"
"012354_5.00123.AR_3.335_8")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")