$re = '/^[A-Z][a-z]*(?:\s[A-Z][a-z]*)*$/m';
$str = 'Joe V
/
Wiktor Stribizew
/
Rikki Tikki Tavi
Some text
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);