// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^[A-Z][a-z]*(?:\s[A-Z][a-z]*)*$").unwrap();
let string = "Joe V
/
Wiktor Stribizew
/
Rikki Tikki Tavi
Some text
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}