re = /^[A-Z][a-z]*(?:\s[A-Z][a-z]*)*$/m
str = 'Joe V
/
Wiktor Stribizew
/
Rikki Tikki Tavi
Some text
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end