using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"START\[(\d+)\]((.|\n|\r)*?)END\[(\d+)\]";
string input = @"START[1]
message to capture ...END[1]
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}