$re = '/START\[(\d+)\]((.|\n|\r)*?)END\[(\d+)\]/m';
$str = 'START[1]
message to capture ...END[1]
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);