package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)START\[(\d+)\]((.|\n|\r)*?)END\[(\d+)\]`)
var str = `START[1]
message to capture ...END[1]
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}