package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?i)^[A-z\u00C0-\u00FF -]+$`)
var str = `Jérôme/ \% = +D@uTié@ç'z áéðíóúýþæö`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}