$re = '/^[A-z\u00C0-\u00FF -]+$/i';
$str = 'Jérôme/ \\% = +D@uTié@ç\'z áéðíóúýþæö';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);