const regex = /^[A-z\u00C0-\u00FF -]+$/i;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^[A-z\\u00C0-\\u00FF -]+$', 'i')
const str = `Jérôme/ \\% = +D@uTié@ç'z áéðíóúýþæö`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}