using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^.*?(SNCF|ACHAT(?!.*?SNCF))";
string input = @"Yes ACHAT CB SNCF 1234
no ACHAT cf SNF 5678
Yes SNCF CB ACHAT 1234
no SNF cf ACHAT 5678
nothing of interest here";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}