re = /^.*?(SNCF|ACHAT(?!.*?SNCF))/m
str = 'Yes ACHAT CB SNCF 1234
no ACHAT cf SNF 5678
Yes SNCF CB ACHAT 1234
no SNF cf ACHAT 5678
nothing of interest here'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end