const regex = new RegExp('^.*?(SNCF|ACHAT(?!.*?SNCF))', 'gm')
const str = `Yes ACHAT CB SNCF 1234
no ACHAT cf SNF 5678
Yes SNCF CB ACHAT 1234
no SNF cf ACHAT 5678
nothing of interest here`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}