import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "[^\\/#?\\n]+\\.(?:css|js)(?![^\\/?#\\n])";
final String string = "https://example.com/_next/static/css/96c1d677121f4c49.css\n"
+ "https://example.com/96c1d677121f4c49.css\n"
+ "96c1d677121f4c49.css\n"
+ "https://example.com/_next/static/css/96c1d677121f4c49.js\n"
+ "https://example.com/96c1d677121f4c49.js\n"
+ "96c1d677121f4c49.js";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}