re = /[^\/#?\n]+\.(?:css|js)(?![^\/?#\n])/m
str = 'https://example.com/_next/static/css/96c1d677121f4c49.css
https://example.com/96c1d677121f4c49.css
96c1d677121f4c49.css
https://example.com/_next/static/css/96c1d677121f4c49.js
https://example.com/96c1d677121f4c49.js
96c1d677121f4c49.js'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end