$re = '/[^\/#?\n]+\.(?:css|js)(?![^\/?#\n])/m';
$str = 'https://example.com/_next/static/css/96c1d677121f4c49.css
https://example.com/96c1d677121f4c49.css
96c1d677121f4c49.css
https://example.com/_next/static/css/96c1d677121f4c49.js
https://example.com/96c1d677121f4c49.js
96c1d677121f4c49.js';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);