package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(local commercial|locaux commerciaux)`)
var str = `REGEX_1 = (local commercial|locaux commerciaux)
REGEX_2NOT =
(à proximité (commerces|
commerces? proche|
commerces? [aà] proximit[ée]|
[aà] proximit[ée](\s\w*)? des? commerces?)
[Encapsuler xxx]
local commercial
locaux commerciaux
[NE PAS TENIR COMPTE]
à proximité (commerces, restaurants)
commerces? proche
commerces? à proximité
à proximité de commerces?
à proximité immédiate des commerces?`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}