import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(local commercial|locaux commerciaux)";
final String string = "REGEX_1 = (local commercial|locaux commerciaux)\n\n"
+ "REGEX_2NOT =\n"
+ "(à proximité (commerces|\n"
+ "commerces? proche|\n"
+ "commerces? [aà] proximit[ée]| \n"
+ "[aà] proximit[ée](\\s\\w*)? des? commerces?)\n\n"
+ "[Encapsuler xxx]\n"
+ "local commercial\n"
+ "locaux commerciaux\n\n\n"
+ "[NE PAS TENIR COMPTE]\n"
+ "à proximité (commerces, restaurants)\n"
+ "commerces? proche\n"
+ "commerces? à proximité \n"
+ "à proximité de commerces?\n"
+ "à proximité immédiate des commerces?";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}