# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(local commercial|locaux commerciaux)"
test_str = ("REGEX_1 = (local commercial|locaux commerciaux)\n\n"
"REGEX_2NOT =\n"
"(à proximité (commerces|\n"
"commerces? proche|\n"
"commerces? [aà] proximit[ée]| \n"
"[aà] proximit[ée](\\s\\w*)? des? commerces?)\n\n"
"[Encapsuler xxx]\n"
"local commercial\n"
"locaux commerciaux\n\n\n"
"[NE PAS TENIR COMPTE]\n"
"à proximité (commerces, restaurants)\n"
"commerces? proche\n"
"commerces? à proximité \n"
"à proximité de commerces?\n"
"à proximité immédiate des commerces?")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.