import Foundation
let pattern = #"(25[0-5]|2[0-4]\d|1?\d\d?)(\.\g<-2>){3}"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
123 hahab abcde 123
//192.168.10.254/10.4.32.21 / 1.2.3 /125.258.33.22/ 432.2.3.475
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #""#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)