using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\b[a-zA-Z]";
string input = @"Ruby on Rails
Complementary metal-oxide semiconductor
GNU Image Manipulation Program
The Road _Not_ Taken
Halley's Commet";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}