package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)\b[a-zA-Z]`)
var str = `Ruby on Rails
Complementary metal-oxide semiconductor
GNU Image Manipulation Program
The Road _Not_ Taken
Halley's Commet`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}