$re = '`\b[a-zA-Z]`m';
$str = 'Ruby on Rails
Complementary metal-oxide semiconductor
GNU Image Manipulation Program
The Road _Not_ Taken
Halley\'s Commet';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);