import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(<p\\s.*?>)(.*?\\.)(<\\/p>)";
final String string = "Вход: <p class=\"c01\">String1.String2.String3.</p>\n\n"
+ "Выход: <p class=\"c01\">String1. <span>...</span> String2. <span>...</span> String3. <span>...</span> </p>\n"
+ " ";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}