// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)(<p\s.*?>)(.*?\.)(<\/p>)").unwrap();
let string = "Вход: <p class=\"c01\">String1.String2.String3.</p>
Выход: <p class=\"c01\">String1. <span>...</span> String2. <span>...</span> String3. <span>...</span> </p>
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}