$re = '/(<p\s.*?>)(.*?\.)(<\/p>)/m';
$str = 'Вход: <p class="c01">String1.String2.String3.</p>
Выход: <p class="c01">String1. <span>...</span> String2. <span>...</span> String3. <span>...</span> </p>
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);