const regex = /(^[^\p{L}]*\p{L}{1})/gmu;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(^[^\\p{L}]*\\p{L}{1})', 'gmu')
const str = `one
two
three
> four
five
.six
..
dfgdf
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}