use strict;
my $str = 'DI_NEO_OP_BRA_CRC_LRN_DIS_EP_NA_CON_UC_NA
DI_NEO_OP_BRA_CRC_LRN_DIS_EP_NA_CON';
my $regex = qr/^(?:[^_\n]*_){9}(CON)(?:_|$)/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}