re = /^(?:[^_\n]*_){9}(CON)(?:_|$)/m
str = 'DI_NEO_OP_BRA_CRC_LRN_DIS_EP_NA_CON_UC_NA
DI_NEO_OP_BRA_CRC_LRN_DIS_EP_NA_CON'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end