$re = '/^(?!.*[@\.\_\d])[A-Za-z\x{00C0}-\x{00FF}][A-Za-z\x{00C0}-\x{00FF}\'\-]+([\ A-Za-z\x{00C0}-\x{00FF}][A-Za-z\x{00C0}-\x{00FF}\'\-]+)*/mu';
$str = 'Pedro
Juan Andrés
Angel María España
Peter Thorne-Smidth
Flor@s
- it doesn\'t match if first comes a space!
- numbers @ _ . and oder special chars are not allowed';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);