import re
regex = re.compile(r"^(?!.*[@\.\_\d])[A-Za-z\x{00C0}-\x{00FF}][A-Za-z\x{00C0}-\x{00FF}\'\-]+([\ A-Za-z\x{00C0}-\x{00FF}][A-Za-z\x{00C0}-\x{00FF}\'\-]+)*", flags=re.MULTILINE | re.UNICODE)
test_str = ("Pedro\n"
"Juan Andrés\n"
"Angel María España\n"
"Peter Thorne-Smidth\n"
"Flor@s\n\n"
"- it doesn't match if first comes a space!\n"
"- numbers @ _ . and oder special chars are not allowed")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")