#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(([a-zA-Z]{2}-?\d{2}-?\d{2})|(\d{2}-?\d{2}-?[a-zA-Z]{2})|(\d{2}-?[a-zA-Z]{2}-?\d{2})|([a-zA-Z]{2}-?\d{2}-?[a-zA-Z]{2})|([a-zA-Z]{2}-?[a-zA-Z]{2}-?\d{2})|(\d{2}-?[a-zA-Z]{2}-?[a-zA-Z]{2})|(\d{2}-?[a-zA-Z]{3}-?\d{1})|(\d{1}-?[a-zA-Z]{3}-?\d{2})|([a-zA-Z]{2}-?\d{3}-?[a-zA-Z]{1})|([a-zA-Z]{1}-?\d{3}-?[a-zA-Z]{2})|([a-zA-Z]{3}-?\d{2}-?[a-zA-Z]{1})|([a-zA-Z]{1}-?\d{2}-?[a-zA-Z]{3})|(\d{1}-?[a-zA-Z]{2}-?\d{3})|(\d{3}-?[a-zA-Z]{2}-?\d{1}))$"
Local $sString = "xx-99-99" & @CRLF & _
"99-99-xx" & @CRLF & _
"99-xx-99" & @CRLF & _
"xx-99-xx" & @CRLF & _
"xx-xx-99" & @CRLF & _
"99-xx-xx" & @CRLF & _
"99-xxx-9" & @CRLF & _
"9-xxx-99" & @CRLF & _
"xx-999-x" & @CRLF & _
"x-999-xx" & @CRLF & _
"xxx-99-x" & @CRLF & _
"x-99-xxx" & @CRLF & _
"9-xx-999" & @CRLF & _
"999-xx-9"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")