// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^(([a-zA-Z]{2}-?\d{2}-?\d{2})|(\d{2}-?\d{2}-?[a-zA-Z]{2})|(\d{2}-?[a-zA-Z]{2}-?\d{2})|([a-zA-Z]{2}-?\d{2}-?[a-zA-Z]{2})|([a-zA-Z]{2}-?[a-zA-Z]{2}-?\d{2})|(\d{2}-?[a-zA-Z]{2}-?[a-zA-Z]{2})|(\d{2}-?[a-zA-Z]{3}-?\d{1})|(\d{1}-?[a-zA-Z]{3}-?\d{2})|([a-zA-Z]{2}-?\d{3}-?[a-zA-Z]{1})|([a-zA-Z]{1}-?\d{3}-?[a-zA-Z]{2})|([a-zA-Z]{3}-?\d{2}-?[a-zA-Z]{1})|([a-zA-Z]{1}-?\d{2}-?[a-zA-Z]{3})|(\d{1}-?[a-zA-Z]{2}-?\d{3})|(\d{3}-?[a-zA-Z]{2}-?\d{1}))$").unwrap();
let string = "xx-99-99
99-99-xx
99-xx-99
xx-99-xx
xx-xx-99
99-xx-xx
99-xxx-9
9-xxx-99
xx-999-x
x-999-xx
xxx-99-x
x-99-xxx
9-xx-999
999-xx-9";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}