#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(?:[1-9][0-9]?(?:\.[0-9]{2})?|100(?:\.00)?)$"
Local $sString = "0" & @CRLF & _
"9" & @CRLF & _
"10" & @CRLF & _
"19" & @CRLF & _
"1" & @CRLF & _
"99" & @CRLF & _
"100" & @CRLF & _
"100.00" & @CRLF & _
"99.01" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"99.1" & @CRLF & _
"100.01"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")