re = /^(?:[1-9][0-9]?(?:\.[0-9]{2})?|100(?:\.00)?)$/m
str = '0
9
10
19
1
99
100
100.00
99.01
99.1
100.01'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end