// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^(?:[1-9][0-9]?(?:\.[0-9]{2})?|100(?:\.00)?)$").unwrap();
let string = "0
9
10
19
1
99
100
100.00
99.01
99.1
100.01";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}