$re = '/(?:(\bpublic\b)\s|(\bprivate\b)\s|(\babstract|partial|sealed\b)\s|(\bclass\b)\s(\b\w+\b)(?:\(.*\)))/';
$str = 'public class Something()
private class SomethingElse(Parameter parameter)
public abstract class IDidNotSeeThis()
private partial class IMissThisToo()
public sealed class INeverWordedWithIt()
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);