// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?:(\bpublic\b)\s|(\bprivate\b)\s|(\babstract|partial|sealed\b)\s|(\bclass\b)\s(\b\w+\b)(?:\(.*\)))").unwrap();
let string = "public class Something()
private class SomethingElse(Parameter parameter)
public abstract class IDidNotSeeThis()
private partial class IMissThisToo()
public sealed class INeverWordedWithIt()
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}