re = /(?:(\bpublic\b)\s|(\bprivate\b)\s|(\babstract|partial|sealed\b)\s|(\bclass\b)\s(\b\w+\b)(?:\(.*\)))/
str = 'public class Something()
private class SomethingElse(Parameter parameter)
public abstract class IDidNotSeeThis()
private partial class IMissThisToo()
public sealed class INeverWordedWithIt()
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end