#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "\b\d+\b"
Local $sString = "(12,12,23),("string",34)" & @CRLF & _
"34" & @CRLF & _
"56-918, 87*73*123 " & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"//Negative" & @CRLF & _
"6do" & @CRLF & _
"text12,text12text" & @CRLF & _
"number2"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")