const regex = /\b\d+\b/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\b\\d+\\b', 'g')
const str = `(12,12,23),("string",34)
34
56-918, 87*73*123
//Negative
6do
text12,text12text
number2`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}