using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\b\d+\b";
string input = @"(12,12,23),(""string"",34)
34
56-918, 87*73*123
//Negative
6do
text12,text12text
number2";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}