package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)\\x1b\[[0-9A-Z]{1,2};([0-9]{1,2})H\\n`)
var str = `\x1b[12;5H\nSomething`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}