// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)\\x1b\[[0-9A-Z]{1,2};([0-9]{1,2})H\\n").unwrap();
let string = "\\x1b[12;5H\\nSomething";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}