$re = '/\\\\x1b\[[0-9A-Z]{1,2};([0-9]{1,2})H\\\\n/m';
$str = '\\x1b[12;5H\\nSomething';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);