using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"([EWSN])([0-9]{3})([0-9]{2})";
string input = @"E16130
W16130
S16130
N16130";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}