package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)([EWSN])([0-9]{3})([0-9]{2})`)
var str = `E16130
W16130
S16130
N16130`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}